Server Stability Improvements

Incident Report for Circular Ring

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 10:17 UTC

Identified

⚙️ Server Stability Status

During periods of high traffic and of American-based users, our servers may limit data processing to maintain stability for all users. This means that some data may appear partially after synchronization.

🔍 Symptoms You Might Notice

If you experience one or more of the following issues, it may be due to temporary server load management:

-Lack of data granularity — gaps or flat zones in your Activity Intensity graph or missing segments in the Activity Duration pie chart (found under the Energy Circle).
-Missing metrics — sleep score, energy level, readiness score, or other related data not showing up after sync.
-Lost steps or incomplete activity records.

🧘 What You Can Do

You can synchronize:
- Daily. If you have more than 24 hours of data in your ring, it increases the chance of losing data.
- During off-peak hours, i.e., not right after you wake up, because everyone synchronizes within a short timeframe.

There’s nothing else you need to do on your side.

🚀 By the End of November 2025

We’re shifting to an architecture where each user gets a dedicated processing calculation instance, so one user’s activity won’t affect another. This upgrade will enable Circular to support millions of users simultaneously with 100% stability for everyone and faster score processing.

Thanks for your patience as we continue improving long-term reliability.
Posted Oct 20, 2025 - 12:56 UTC
This incident affects: Biometrics Processing.