Data Processing Delays

Incident Report for Circular Ring

Identified

We’ve identified an issue where sleep detection may not trigger during the first data synchronization of the day. Our team is already working on a permanent fix.

🔧 Temporary solution: If this happens, simply close the app completely (swiped from background) and run another data sync later. This will trigger the sleep analysis correctly.

To ensure long-term stability, we’ve added extra security layers around data synchronization, so that the servers remain stable and all users can upload their data without issues.

✅ Rest assured: No data will be lost. We will also reprocess sleep data for all users, so your records remain accurate and complete.
Posted Sep 24, 2025 - 07:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 23, 2025 - 08:57 UTC

Monitoring

Over the past few days, some of you may have experienced outages with our servers. We sincerely apologize for the inconvenience.

We monitor our systems real time and we are aware of outages the minute they happen.

Why These Outages Happened

Several overlapping factors contributed to instability:

-Server-side updates and scheduled maintenance performed by our cloud provider.
-Load growth driven by the increasing number of Circular users.
-Connection spikes due to syncs happening at peak times.

We had anticipated the surge in connections and informed our providers in advance, but the overlap of these events unfortunately caused instability and temporary shutdowns.

Current Status

Please know that our top priority is to stabilize everything as quickly as possible. As of this morning, all systems are back up and running with degraded performance.

Your data won't be lost

While we work on long-term fixes, some inconveniences might still occur in the coming weeks. That being said, your data is not LOST:

-Any data synced from your ring to your phone is first stored locally on your phone until it can be uploaded to the server.
-The ring itself has 7 days of onboard memory, ensuring nothing is lost even during a downtime of 48 hours.

Not a Ring Issue

These outages are not related to the ring itself. Your hardware is working correctly.

-An “ES02 error” means the app cannot reach the server.
-If the app takes a long time to open or crashes on the splash screen, this is also due to failed server communication—not a hardware issue.
-The same applies when you cannot access your historical data.

We fully recognize that the app should still open and function locally even when servers are down, and we are working on fixes to improve this.

What NOT to do

Uninstalling the app or logging out will not solve the issue. On the contrary, these actions will erase the data stored on your phone, making the problem worse for you.

What to DO

The best approach during a server outage is simply to wait and try again the next day. Your data will sync automatically once the servers are back online.

Why Weekends Are More Impacted

Communication with our providers can be more difficult on weekends until systems are relaunched, which is why downtime may sometimes last up to 48 hours.

Our Next Steps

We are working closely with our service providers to reinforce stability and scale infrastructure as Circular continues to grow. Our technical priority remains ensuring reliability at scale.

Status Page

You can always track live updates on our status page: https://circularring.statuspage.io/.
Currently, it only reflects outages from our own infrastructure, but we are working on extending it so that you can also see external related issues in real time.

We are committed to continuous improvements and full transparency with you. Thank you again for your understanding and trust as we scale together.

— The Circular Team
Posted Sep 22, 2025 - 17:28 UTC
This incident affects: Biometrics Processing.